HealthStream Authoring Center - Contribute Pages

Version 1

    How do I add audio or video to Contribute pages in Authoring Center?       

      

    The Authoring Center supports Flash files (.swf) that are capable of playing embedded audio and video, as well as any number of animations and multimedia interactions. The Authoring Center does not support standalone audio file formats (e.g., .mp3, .wav, .mpeg, etc.). It does  support the same standalone video file formats that Contribute supports (e.g., .wmv, .mov,.qt, .avi, .mpg, .mpeg, and .mp4).  

     

    To add an audio file, follow these steps:

    1. 1.     Save the audio clip as a .swf file on your computer.
    2. 2.     Browse/navigate to the .swf file location you wish to add.
    3. 3.     Open the content page in which you will add the audio file.
    4. 4.     Copy (CTRL+C) and paste (CTRL+V) or click and drag the .swf file onto your content page. 

    To add a video file:

    1. 1.     Save (“Save as”) the video clip as a .swf , .wmv, .mov, .qt, .avi, .mpg, .mpeg, or .mp4 file type on your computer.
    2. 2.     Browse/navigate to the video file you wish to add.
    3. 3.     Open the content page in which you will add the video file.
    4. 4.     Copy (CTRL+C) and paste (CTRL+V) or click and drag the video file onto your content page.

    Another way to add the file after it has been saved in the appropriate format is to:

    1. 1.     From within Contribute, select Insert -> Movie/Audio from “My Computer” and browse to the file location.
    2. 2.     Click “Insert.”

    Tip: If you need software to convert audio files, you can use Format Factory: http://www.formatoz.com/. However, HealthStream does not recommend for or against it and does not provide support for its use.

     

    How do I add tables in Contribute?

     

    There are two ways to add tables in Contribute:

    1. 1.     Highlight the table/area you want to copy in a Microsoft Word document or Excel worksheet. Copy (CTRL+C) the higlighted information and paste (CTRL+V) directly into your Contribute page.
    2. 2.     Create a table within Contribute by selecting the Table button on the page. Choose “Insert Table” menu and fill in the desired number of rows, columns, border thickness, and header style information. Click “OK and the table will be added to your page. Select any cell to type, paste text, or insert graphics.

     

    How do I create additional pages in Contribute?

     

     

    1. Open the page you wish to use as your template.
      1. If you have just created a page, you can use this page as your template and go to Step 2.
      2. If you want to use another page as your template or you have just opened the Authoring Center, click the Choose button.
      3. Navigate to the page you want to use as a template, highlight it, and click OK.
    2. Click New Page, and then Copy of Current Page.
    3. Type a page title. Do not use spaces or special characters.
    4. Click OK.
    5. Using this editor, delete the text and image from the previous page and add text and images for the new page. For more information on adding content to your pages.
    6. Click Publish from the Contribute menu.

    Tip:When you publish subsequent pages of online content, the page will automatically point to the folder you created and saved the first page to. Guidelines for Naming Pages

    • Name the page using the page title or another unique name.
    • Begin filenames with a numeric value and an underscore in increments of ten. The number before a page name indicates its order in your course. Beginning with an increment of ten allows you to insert pages between your pages later. (Example:  010_Introduction)
    • Do not include numbers after the underscore. ( Example: 010_1Introduction)
    • Do not include spaces in the file name. ( Example: 020 Overview)
    • Do not use these special characters: ~, !, @, #, $, %, ^, &, *,(, ), +, =, `, ', :, ;, ?, /, \, <,  and >. Example: <introduction> is not a valid file name.
    • Do separate words with an underscore or capital letters. (Example:  030_Emergency_Procedures OR 030_EmergencyProcedures)
    • If you name your file incorrectly, see Renaming Courses in the HealthStream Authoring Center Guide (found in the HLC Help system).

    Guidelines for Naming Content Folders

    • Give the content folder a name similar to the course to be created in the HLC Course Builder.
    • Separate words in the folder name with an underscore.
    • Limit the name of your course to 50 characters or less.

     

    NOTE: The name you assign the content folder is not displayed to students. In Course Builder, you can rename the Authoring Center activity name which will display for students, as well as a assigning a name for the course in which the activity resides. For more Help, refer to the HLC Authoring Center online help in the HLC.

     

    How do I format pages in Authoring Center using Contribute?

     

     

    Adding Text

    To add text to an Authoring Center page, delete the existing text in the template and type your new text. Or, if you have created a storyboard in another program, copy and paste the text into your course page.

    Note: If prompted to “Clean Up Word HTML?” click Yes.

    Adding Images

    You can add images four different ways:

    • Copy and paste images from your Microsoft Word storyboard.
    • Add images from HealthStream assets.
    • Add images saved on your hard drive or network.
    • Add images from the Internet.

    Save all images you add to your course in .JPG or .GIF format. This format keeps the file size small and makes your course pages open faster. Contribute takes care of uploading the images to the HLC, automatically. Note: Do not attempt to copy images from one Authoring Center activity to another. Instead, add the image from its original location (e.g. hard drive, network drive, Internet, or Word document) by accessing the Images button within Contribute. If you copy an image from one activity and paste it into another, the image will not show in the activity you paste it to. Copying and Pasting Images from Your Microsoft Word Storyboard

    1. Right-click on the image in your storyboard in Microsoft Word, and click Copy.
    2. Right-click in the location on your content page where you want to add the image, and click Paste.

    Note: You may also click on the image and use the Ctrl-C (copy), and then click on the content page where you want to add the image and use Ctrl-V (paste). Adding Images from HealthStream Assets

    1. Click in the location on your course page where you want to add the image.
    2. Click the Image icon and select From Website…
    3. Browse to the folder named Courseware Exchange Community.
    4. Open the folder HealthStream_Provided_Assets and open the folder Images.
    5. Browse to the image you want to add.
    6. Click on the name of the image, and click OK.

    Adding Images Saved On Your Hard Drive or Network

    1. Click in the location on your content page where you want to add the image.
    2. Click the Image icon and select From My Computer…
    3. Browse to the folder that contains your images.
    4. Click on the name of the image, and click Select.

    Adding Images from the Internet

    1. You can add images to your content pages from any website by dragging and dropping the image from Internet Explorer onto your open page in Contribute.
    2. You can also save the image from the web site by right-clicking it and selecting Save As
    3. Then, follow the steps for Adding Images Saved on Your Hard Drive or Network above.

    Note: Be sure to follow your organization’s policies and procedures for obtaining appropriate copyright permission to use images found on the Internet.

     

    Insert Background Template

     

    1. Click the Courses tab.
    2. Click FTP Connection.

    a. A pop-up window will appear for the FTP root at authordev.healthstream.com. To view this FTP site in Windows Explorer, click Page

    b. Then click Open FTP Site in Windows Explorer.

    c  Enter FTP Username / FTP Password.

    d. Click login button. 

    1. Find and open the Image folder.
    2. Find the jpg image you would like to use. Drag and drop the image into the Image folder.
    3. Go into Contribute and create a new page or use a current unpublished draft.
    4. In edit mode, click the Proprieties button in the upper right corner.
    5. On the left side, click Appearance.
    6. Scroll to Background image and click Browse (Images on Website).
    7. Find Image folder and open, select your image and it will appear as the background.

     

    How do I insert links in Contribute pages?      

     

    To insert a hyperlink to document file on your computer, follow these steps:

    1. Use your mouse to highlight the text or graphic on your content page that you want to link to the file.
    2. Click the link icon and choose “File on My Computer.”
    3. Browse on your computer to locate the file you want to link to and click on it to choose the file.
    4. If you would like to have the link launch in a new window (recommended), set the target frame to “New Window.”
    5. Click “OK” and you will see the link appear on the content page.

    NOTE: When creating a link to a document, Contribute makes a copy of the document  and stores it within the content folder. If changes are made to the original source file,  those changes will not be reflected in the document within the Authoring Center activity. You must update the page to which the document is linked by linking to the updated  document, and then publish the page. Once the update is made, any previously published HLC course that includes the Authoring Center activity must be republished for the updated document link to be available to students.

     

    To insert a hyperlink to another webpage, follow these steps:

    1. Use your mouse to highlight the text or graphic on your content page that you want to link webpage.
    2. Click the link icon and choose “Browse to Web Page.”
    3. In the “Web address (URL)” field, insert the address you would like to link to by copying it from another window/browser tab (right click/copy or CTRL+C) pasting (right click/paste or CTRL+V) the URL from the address field of a browser, manually typing the URL/Web address you would like to link to, or by choosing the “Browse” button to open the page you would like to link to.
    4. If you would like to have the link launch in a new window (recommended), set the target frame to “New Window.”
    5. Click “OK” and you will see the link appear on the content page.

     

    To insert a link to an email address, follow these steps:

    1. 1.     Use your mouse to highlight the text or graphic on your content page that you want to link to the file.
    2. 2.     Click the link icon and choose “Email Address.”
    3. 3.     Enter the email address you wish to link to.
    4. 4.     If you would like to have the link launch in a new window (recommended), set the target frame to “New Window.”
    5. 5.     Click “OK” and you will see the link appear on the content page. Once the content page is published, the link is live and will open in  the default mail server used on the user’s computer.

     

    How can I resize an image in Contribute?

     

    There are two way to change the size of an image: visually or manually entering specific values.

    To resize an image visually, follow these steps:

    1. Select the image in your draft that you want to resize.
    2. Choose the “Resize” button in the Image Editing toolbar.
    3. Drag one of the selection handles on the image to enlarge or shrink to the desired image size.

    Contribute changes the height and width of the image by the same percentage so that the image is not distorted. If you do not want to keep the same ratio as the original image, hold the Shift key as you drag your mouse to change the size.

     

    To resize an image by entering specific height and width measurements, follow these steps:

    1. Select the image in your draft that you want to resize.
    2. Click the Image Properties toolbar.
    3. Enter the desired width and height values in the Image Properties popup window and click “OK.” 

     

    Notes: Resizing in your draft affects the image size and its display area on the page. To  change only the display area, see “Changing Image Properties” on Page 97 of the Contribute User Guide (found via the “Support” link in Authoring Center). Avoid resizing an image to be much larger than its original size. This causes it to appear blurry and distorted. To revert an image to its original size, select the image and then click  Format > Edit Image > Revert to Original Size.